Production Response Time Increase
Incident Report for PayWhirl Inc.
Resolved
This incident has been resolved. It was a fairly technical issue but stemmed from a traffic bottleneck. The related database activity spiraled into a failed environment health check, resulting in "hick-ups" from our load balancers, which ultimately slowed our server response times for both businesses and customers. Once we were able to identify the issue, we restarted our load balancers and all systems were back up and running quickly.

NO DATA WAS LOST DURING THIS INCIDENT AND WE SINCERELY APOLOGIZE FOR ANY INCONVENIENCE THIS HAS CAUSED YOUR BUSINESS.

The good news is are prepared for this sort of problem and already had systems in place to protect your data against outages. When problems occur with PayWhirl, our backup queuing systems ensure that scheduled invoices and payemnts will resume normally when services become operational again.

Thanks again for your patience. Please let us know if you have any questions.

The PayWhirl Team
Posted May 11, 2018 - 10:09 PDT
Monitoring
A fix was implemented at 9:10AM PST and we are monitoring. We will mark the issue as resolved and provide more information shortly. Thanks again for your patience.
Posted May 11, 2018 - 09:44 PDT
Identified
We've identified the source of the issue and are working on correcting the problem. Dashboard statistics may be effected while we work on the issue. Thank you for your patience!
Posted May 11, 2018 - 09:28 PDT
Investigating
We are currently investigating an increase in database response time that began around 1:00AM PST. We will keep you posted while we work on the issue.
Posted May 11, 2018 - 08:39 PDT
This incident affected: PayWhirl.com, PayWhirl REST API, Invoice Processing Queue, and Payment Widgets & Customer Portals.