PayWhirl slow response times
Incident Report for PayWhirl Inc.
Resolved
This incident has been resolved.
Posted Jan 21, 2021 - 12:30 PST
Monitoring
A fix has been implemented and we're monitoring the results. All systems are operational as of 11:30 AM PST.
Posted Jan 21, 2021 - 11:49 PST
Identified
We've identified the issue and are working on a fix now. An unusually large number of API requests are being made from several large accounts and it's causing a bottleneck on our system resources. As a result, we'll be lowering the API rate limit to 60 calls per minute until the issue is fully resolved.
Posted Jan 21, 2021 - 10:32 PST
Investigating
We're investigating an issue that is causing slow response times for our multi-platform app at https://app.paywhirl.com
Posted Jan 21, 2021 - 09:47 PST
This incident affected: PayWhirl.com, PayWhirl REST API, Invoice Processing Queue, and Payment Widgets & Customer Portals.