Multi-Platform Backend Outage

Incident Report for PayWhirl Inc.

Monitoring

We identified the cause, which was due to a spike in web requests, and are monitoring. The backend system is now responding normally for most users.
Posted May 15, 2026 - 15:45 PDT

Update

We are continuing to investigate this issue.
Posted May 15, 2026 - 15:37 PDT

Investigating

We are investigating reports of an issue with the admin side of PayWhirl.com (merchant-facing). We'll report back with updates ASAP.
Posted May 15, 2026 - 15:36 PDT
This incident affects: PayWhirl.com.