Some invoices were being retried inadvertently this morning.
Incident Report for PayWhirl Inc.
Resolved
The issue has been resolved. The bug affected 30 invoices in the system, across all PayWhirl accounts. We sincerely apologize if your account was impacted and are happy to assist if you have any questions regarding this issue. Please feel free to reach out through chat if you need anything from the team. We will be debriefing over the next couple of days to see what we can do to try and prevent issues like this from occurring in the future. We appreciate your prompt reporting of the problem, and your patience while we worked to get it resolved.
Posted Apr 20, 2020 - 09:26 PDT
Monitoring
This morning we identified an issue where some invoices were being retried inadvertently. The problem may have caused some payments to be reattempted repeatedly. PayWhirl's invoice processor had a bug with locking invoices that surfaced when the queue became larger than the scheduler interval, which spiked at 6 AM PST this morning. This lead to invoices getting queued many times over until the team identified the issue. We deployed a fix for the bug at 8:24 AM PST and are monitoring to make sure everything has returned to normal.

We sincerely apologize if your account was impacted and are happy to assist if you have any questions regarding this issue. Please feel free to reach out through chat if you need anything from the team.
Posted Apr 20, 2020 - 08:32 PDT
This incident affected: Invoice Processing Queue.