Slow load times on PayWhirl multi-platform app.
Incident Report for PayWhirl Inc.
Resolved
The fix we employed yesterday seemed to work for the vast majority of users. Unfortunately, it seems like it was temporary as the system went down again. Our developers narrowed things down to a database bottleneck and released an upgrade this morning.

The was system down while the upgrade was processed (approx. 25 mins) but the update resolved the issue and has improved performance through the application. We appreciate your patience and will continue to give updates on PayWhirl's status in the future should any issues arise.

Please note that all background jobs were unaffected, and your active subscriptions will behave normally.
Posted Jan 19, 2022 - 11:24 PST
Monitoring
We have implemented a fix for the slow load times reported earlier today, and are now monitoring. The issue seems to be resolved but we will continue to monitor and update accordingly. Widgets, background process, and the app are running smoothly as of now.
Posted Jan 18, 2022 - 15:08 PST
Identified
We've identified the root of the issue and are working on a fix currently. We'll keep you posted as things progress.
Posted Jan 18, 2022 - 14:54 PST
Investigating
This morning at approximately 7:30 AM PST, we began investigating an issue with slow loading times on our multi-application app. Please note that all your data is safe, and background processes do not seem to be affected. However, while we investigate the issue, you may experience slower than expected loading times when viewing the app. This issue is NOT affecting businesses using our new Shopify app, only on https://app.paywhirl.com

Our developers have been exploring, and we will provide updates here as we have them. Thank you for your patience.
Posted Jan 18, 2022 - 13:37 PST
This incident affected: PayWhirl.com, PayWhirl REST API, Invoice Processing Queue, and Payment Widgets & Customer Portals.